Debian Lenny, /etc/apt/sources.list and error 404

Since Debian Lenny is now deprecated and no longer supported, its packages are now removed from the mirrors. Because of this, you may experience 404 when trying to install the packages with apt-get, or update sources lists.

If you’re not going to upgrade to Debian Squeeze, here are /etc/apt/sources.list lines giving you access to Lenny packages (stored on archive.debian.org servers):

If you’re getting the following error:

you have to use the “-o Acquire::Check-Valid-Until=false” option: